Tampilkan postingan dengan label ANALISIS PERANCANGAN JARINGAN KOMPUTER. Tampilkan semua postingan
Tampilkan postingan dengan label ANALISIS PERANCANGAN JARINGAN KOMPUTER. Tampilkan semua postingan

IP versi 6

Pada tulisan ini saya akan menjelaskan mengenai IP versi 6 dan bagaimana cara
pengalokasiannya, dimana artikel ini pernah dimuat di majalah Infokomputer.
Saat ini untuk request IP address dilakukan melalui lembaga yang telah ditunjuk oleh IANA
(Internet Assigned Numbers Authority) yang ditentukan berdasarkan wilayah, diantaranya adalah
APNIC (Asia Pacific Network Information Center) yang khusus menangani request IP address
untuk wilayah Asia Pasifik, diantaranya wilayah yang dilayani oleh APNIC adalah Indonesia.
Organisasi serupa yang menangani kawasan Amerika Utara, Amerika Selatan, Karibia, dan Afrika
Sub Sahara adalah ARIN, sedangkan di Eropa, Timur Tengah, dan sebagian Afrika adalah RIPENCC.
IP address yang bahasa awamnya bisa disebut dengan kode pengenal komputer pada jaringan/
Internet memang merupakan komponen vital pada Internet, karena tanpa IP address sudah pasti
tidak akan dikenal Internet. Setiap komputer yang terhubung ke Internet setidaknya harus
memiliki sebuah IP address pada setiap interfacenya dan IP address sendiri harus unik karena
tidak boleh ada komputer/server/perangkat network lainnya yang menggunakan IP address yang
sama di Internet. IP address adalah sederetan bilangan binary sepanjang 32 bit, yang dipakai untuk
mengidentifikasi host pada jaringan. IP address ini diberikan secara unik pada masing-masing
komputer/host yang tersambung ke internet. Packet yang membawa data, dimuati IP address dari
komputer pengirim data, dan IP address dari komputer yang dituju, kemudian data tersebut
dikirim ke jaringan. Packet ini kemudian dikirim dari router ke router dengan berpedoman pada IP
address tersebut, menuju ke komputer yang dituju. Seluruh host/komputer yang tersambung ke
Internet, dibedakan hanya berdasarkan IP address ini, jadi jelaslah bahwa tidak boleh terjadi
duplikasi. Sehingga IP address ini dibagikan oleh beberapa organisasi yang memiliki otoritas atas
pembagian IP address tersebut, seperti APNIC (Asia Pacific Network Information Center).
Pada IPv4 ada 3 jenis Kelas, tergantung dari besarnya bagian host, yaitu kelas A (bagian host
sepanjang 24 bit , IP address dapat diberikan pada 16,7 juta host) , kelas B (bagian host sepanjang
16 bit = 65534 host) dan kelas C (bagian host sepanjang 8 bit = 254 host ). Administrator jaringan
mengajukan permohonan jenis kelas berdasarkan skala jaringan yang dikelolanya. Konsep kelas
ini memiliki keuntungan yaitu : pengelolaan rute informasi tidak memerlukan seluruh 32 bit
tersebut, melainkan cukup hanya bagian jaringannya saja, sehingga besar informasi rute yang
 disimpan di router, menjadi kecil. Setelah address jaringan diperoleh, maka organisasi tersebut
dapat secara bebas memberikan address bagian host pada masing-masing hostnya.
Pemberian alamat dalam internet mengikuti format IP address (RFC 1166). Alamat ini dinyatakan
dengan 32 bit (bilangan 1 dan 0) yang dibagi atas 4 kelompok (setiap kelompok terdiri dari 8 bit
atau oktet) dan tiap kelompok dipisahkan oleh sebuah tanda titik. Untuk memudahkan pembacaan,
penulisan alamat dilakukan dengan angka desimal, misalnya 100.3.1.100 yang jika dinyatakan
dalam binary menjadi 01100100.00000011.00000001.01100100. Dari 32 bit ini berarti banyaknya
jumlah maksimum alamat yang dapat dituliskan adalah 2 pangkat 32, atau 4.294.967.296 alamat.
Format alamat ini terdiri dari 2 bagian, netid dan hostid. Netid sendiri menyatakan alamat jaringan
sedangkan hostid menyatakan alamat lokal (host/router).
Dari 32 bit ini, tidak boleh semuanya angka 0 atau 1 (0.0.0.0 digunakan untuk jaringan yang tidak
dikenal dan 255.255.255.255 digunakan untuk broadcast). Dalam penerapannya, alamat internet
ini diklasifikasikan ke dalam kelas (A-E).
Alasan klasifikasi ini antara lain :
♦ Memudahkan sistem pengelolaan dan pengaturan alamat-alamat.
♦ Memanfaatkan jumlah alamat yang ada secara optimum (tidak ada alamat yang terlewat).
♦ Memudahkan pengorganisasian jaringan di seluruh dunia dengan membedakan jaringan
tersebut termasuk kategori besar, menengah, atau kecil.
♦ Membedakan antara alamat untuk jaringan dan alamat untuk host/router.
Pada tabel dibawah dijelaskan mengenai ketersediaan IPv4 berdasarkan data dari APNIC sampai
akhir tahun 1999 yang lalu dan total IP yang sudah dialokasikan ke tiap – tiap negara di Asia
Pasifik..






Perkembangan Internet dan network akhir-akhir ini telah membuat Internet Protocol (IP) yang
merupakan tulang punggung networking berbasis TCP/IP dengan cepat menjadi ketinggalan
zaman, saat ini berbagai macam aplikasi yang menggunakan Internet, diantaranya transfer file
(ftp), surat elektronik (e-mail), akses jarak jauh (remote access), Multimedia menggunakan
Internet, dan lain sebagainya. Perkembangan ini telah membuat terlampauinya kapasitas jaringan
berbasis IP untuk mensuplai layanan dan fungsi yang diperlukan. Sebuah lingkungan seperti
Internet membutuhkan dukungan pada lalu-lintas data secara real-time maupun fungsi sekuriti.
Kebutuhan akan fungsi sekuriti ini saat ini sangat sulit dipenuhi oleh IP versi 4 atau sering disebut
IPv4. Hal ini mendorong para ahli untuk merumuskan Internet Protocol baru untuk
menanggulangi keterbatasan resource Internet Protocol yang sudah mulai habis serta menciptakan
Internet Protocol yang memiliki fungsi sekuriti yang reliability.
Pada tanggal 25 Juli di Toronto pada saat pertemuan IETF telah direkomendasikan penggunaan
IPv6 atau ada yang menyebutnya dengan IPng (IP next generation) yang dilatarbelakangi oleh
keterbatasan IPv4 yang saat ini memiliki panjang 32 bit, akibat ledakan pertumbuhan jaringan.
Pengembangan IPv6, atau ada yang menyebutkan dengan nama IP Next Generation yang
direkomendasikan pada pertemuan IETF di Toronto tanggal 25 Juli 1994 dilatarbelakangi oleh
kekurangan IP address yang saat ini memiliki panjang 32 bit, akibat ledakan pertumbuhan
jaringan. IPv6 merupakan versi baru dari IP yang merupakan pengembangan dari IPv4.
Keunggulan IPv6 :
a. Otomatisasi berbagai setting / Stateless-less auto-configuration (plug&play)
Address pada IPv4 pada dasarnya statis terhadap host. Biasanya diberikan secara berurut pada
host. Memang saat ini hal di atas bisa dilakukan secara otomatis dengan menggunakan DHCP
(Dynamic Host Configuration Protocol), tetapi hal tersebut pada IPv4 merupakan fungsi tambahan
saja, sebaliknya pada IPv6 fungsi untuk mensetting secara otomatis disediakan secara standar dan
merupakan defaultnya. Pada setting otomatis ini terdapat 2 cara tergantung dari penggunaan
address, yaitu setting otomatis stateless dan statefull.
♦ Setting otomatis stateless, pada cara ini tidak perlu menyediakan server untuk pengelolaan
dan pembagian IP address, hanya mensetting router saja dimana host yang telah tersambung
di jaringan dari router yang ada pada jaringan tersebut memperoleh prefix dari address dari
jaringan tersebut. Kemudian host menambah pattern bit yang diperoleh dari informasi yang
unik terhadap host, lalu membuat IP address sepanjang 128 bit dan menjadikannya sebagai IP
address dari host tersebut. Pada informasi unik bagi host ini, digunakan antara lain address
MAC dari jaringan interface. Pada setting otomatis stateless ini dibalik kemudahan
pengelolaan, pada Ethernet atau FDDI karena perlu memberikan paling sedikit 48 bit (sebesar
address MAC) terhadap satu jaringan, memiliki kelemahan yaitu efisiensi penggunaan address
yang buruk.

♦ Setting otomatis statefull adalah cara pengelolaan secara ketat dalam hal range IP address
yang diberikan pada host dengan menyediakan server untuk pengelolaan keadaan IP address,
dimana cara ini hampir mirip dengan cara DHCP pada IPv4. Pada saat melakukan setting
secara otomatis, informasi yang dibutuhkan antara router, server dan host adalah ICMP
(Internet Control Message Protocol) yang telah diperluas. Pada ICMP dalam IPv6 ini,
termasuk pula IGMP (Internet Group management Protocol) yang dipakai pada multicast pada
IPv4.
Keamanan (IP layer privacy and authentication)
Saat ini metode dengan menggunakan S-HTTP(Secure HTTP) untuk pengiriman nomor kartu
kredit, ataupun data pribadi dengan mengenkripsinya, atau mengenkripsi e-mail dengan PGP
(Pretty Good Privacy) telah dipakai secara umum. Akan tetapi cara di atas adalah securiti yang
ditawarkan oleh aplikasi. Dengan kata lain bila ingin memakai fungsi tersebut maka kita harus
memakai aplikasi tersebut. Jika membutuhkan sekuriti pada komunikasi tanpa tergantung pada
aplikasi tertentu maka diperlukan fungsi sekuriti pada layer TCP atau IP, karena IPv4 tidak
mendukung fungsi sekuriti ini kecuali dipasang suatu aplikasi khusus agar bisa mendukung
sekuriti. Dan IPv6 mendukung komunikasi terenkripsi maupun Authentication pada layer IP.
Dengan memiliki fungsi sekuriti pada IP itu sendiri, maka dapat dilakukan hal seperti packet yang
dikirim dari host tertentu seluruhnya dienkripsi. Pada IPv6 untuk Authentication dan komunikasi
terenkripsi memakai header yang diperluas yang disebut AH (Authentication Header) dan payload
yang dienkripsi yang disebut ESP (Encapsulating Security Payload). Pada komunikasi yang
memerlukan enkripsi kedua atau salah satu header tersebut ditambahkan.
Fungsi sekuriti yang dipakai pada layer aplikasi, misalnya pada S-HTTP dipakai SSL sebagai
metode encripsi, sedangkan pada PGP memakai IDEA sebagai metode encripsinya. Sedangkan
manajemen kunci memakai cara tertentu pula. Sebaliknya, pada IPv6 tidak ditetapkan cara tertentu
dalam metode encripsi dan manajemen kunci. Sehingga menjadi fleksibel dapat memakai metode
manapun. Hal ini dikenal sebagai SA (Security Association).
Fungsi Sekuriti pada IPv6 selain pemakaian pada komunikasi terenkripsi antar sepasang host,
dapat pula melakukan komunikasi terenkripsi antar jaringan dengan cara mengenkripsi packet
oleh gateway dari 2 jaringan yang melakukan komunikasi tersebut.
Perbaikan utama lain dari IPv6 adalah:
♦ Streamlined header format and flow identification
♦ Expanded addressing capability
♦ More efficient mobility options
♦ Improved support for options/extensions,
Kegunaan perbaikan tersebut dimaksudkan agar dapat merespon pertumbuhan Internet,
meningkatkan reliability, maupun kemudahan pemakaian.
Perubahan terbesar pada IPv6 adalah perluasan IP address dari 32 bit pada IPv4 menjadi 128 bit.
128 bit ini adalah ruang address yang kontinyu dengan menghilangkan konsep kelas. Selain itu
juga dilakukan perubahan pada cara penulisan IP address. Jika pada IPv4 32 bit dibagi menjadi
masing-masing 8 bit yang dipisah kan dengan "." dan di tuliskan dengan angka desimal, maka
pada IPv6, 128 bit tersebut dipisahkan menjadi masing-masing 16 bit yang tiap bagian dipisahkan
dengan ":"dan dituliskan dengan hexadesimal. Selain itu diperkenalkan pula struktur bertingkat
agar pengelolaan routing menjadi mudah. Pada CIDR (Classless Interdomain Routing) tabel
routing diperkecil dengan menggabungkan jadi satu informasi routing dari sebuah organisasi

 Untuk memahami tentang struktur bertingkat address pada IPv6 ini, dengan melihat contoh pada
address untuk provider. Pertama-tama address sepanjang 128 bit dibagi menjadi beberapa field
yang dapat berubah panjang. Jika 3 bit pertama dari address adalah "010", maka ini adalah ruang
bagi provider. Sedangkan n bit berikutnya adalah registry ID yaitu field yang menunjukkan
tempat/lembaga yang memberikan IP address. Misalnya IP address yang diberikan oleh InterNIC
maka field tersebut menjadi "11000". Selanjutnya m bit berikutnya adalah provider ID, sedangkan
o bit berikutnya adalah Subscriber ID untuk membedakan organisasi yang terdaftar pada provider
tersebut. Kemudian p bit berikutnya adalah Subnet ID, yang menandai kumpulan host yang
tersambung secara topologi dalam jaringan dari organisasi tersebut. Dan yang q=125-(n+m+o+p)
bit terakhir adalah Interface ID, yaitu IP address yang menandai host yang terdapat dalam grupgrup
yang telah ditandai oleh Subnet ID. Subnet ID dan Interface ID ini bebas diberikan oleh
organisasi tersebut.
Organisasi bebas menggunakan sisa p+q bit dari IP address dalam memberikan IP address di
dalam organisasinya setelah mendapat 128-(p+q) bit awal dari IP address. Pada saat itu,
administrator dari organisasi tersebut dapat membagi menjadi bagian sub-jaringan dan host dalam
panjang bit yang sesuai, jika diperlukan dapat pula dibuat lebih terstruktur lagi. Karena panjang bit
pada provider ID dan subscriber ID bisa berubah, maka address yang diberikan pada provider dan
jumlah IP address yang dapat diberikan oleh provider kepada pengguna dapat diberikan secara
bebas sesuai dengan kebutuhan. Pada IPv6 bagian kontrol routing pada address field disebut
prefix, yang dapat dianggap setara dengan jaringan address pada IPv4.
Address IPv6 dapat dibagi menjadi 4 jenis, yaitu :
♦ Unicast Address (one-to-one) digunakan untuk komunikasi satu lawan satu, dengan menunjuk
satu host.

Pada Unicast address ini terdiri dari :
􀂙 Global, address yang digunakan misalnya untuk address provider atau address geografis.
􀂙 Link Local Address adalah address yang dipakai di dalam satu link saja. Yang dimaksud
link di sini adalah jaringan lokal yang saling tersambung pada satu level. Address ini
dibuat secara otomatis oleh host yang belum mendapat address global, terdiri dari 10+n
bit prefix yang dimulai dengan "FE80" dan field sepanjang 118-n bit yang menunjukkan
nomor host. Link Local Address digunakan pada pemberian IP address secara otomatis.
􀂙 Site-local, address yang setara dengan private address, yang dipakai terbatas di dalam site
saja. Address ini dapat diberikan bebas, asal unik di dalam site tersebut, namun tidak bisa
mengirimkan packet dengan tujuan alamat ini di luar dari site tersebut.
􀂙 Compatible.



 komunikasi dalam segmen yang sama yang dipisahkan oleh gateway, sama halnya dengan
multicast address dipilah berdasarkan range tujuan.

 


♦ Anycast Address, yang menunjuk host dari group, tetapi packet yang dikirim hanya pada satu
host saja.Pada address jenis ini, sebuah address diberikan pada beberapa host, untuk
mendifinisikan kumpulan node. Jika ada packet yang dikirim ke address ini, maka router akan
mengirim packet tersebut ke host terdekat yang memiliki Anycast address sama. Dengan kata
lain pemilik packet menyerahkan pada router tujuan yang paling "cocok" bagi pengiriman
packet tersebut. Pemakaian Anycast Address ini misalnya terhadap beberapa server yang
memberikan layanan seperti DNS (Domain Name Server). Dengan memberikan Anycast
Address yang sama pada server-server tersebut, jika ada packet yang dikirim oleh client ke
address ini, maka router akan memilih server yang terdekat dan mengirimkan packet tersebut
ke server tersebut. Sehingga, beban terhadap server dapat terdistribusi secara merata.Bagi
Anycast Address ini tidak disediakan ruang khusus. Jika terhadap beberapa host diberikan
sebuah address yang sama, maka address tersebut dianggap sebagai Anycast Address

  Struktur Packet pada IPv6
Dalam pendesignan header packet ini, diupayakan agar cost/nilai pemrosesan header menjadi kecil
untuk mendukung komunikasi data yang lebih real time. Misalnya, address awal dan akhir
menjadi dibutuhkan pada setiap packet. Sedangkan pada header IPv4 ketika packet dipecah-pecah,
ada field untuk menyimpan urutan antar packet. Namun field tersebut tidak terpakai ketika packet
tidak dipecah-pecah. Header pada Ipv6 terdiri dari dua jenis, yang pertama, yaitu field yang
dibutuhkan oleh setiap packet disebut header dasar, sedangkan yang kedua yaitu field yang tidak
selalu diperlukan pada packet disebut header ekstensi, dan header ini didifinisikan terpisah dari
header dasar. Header dasar selalu ada pada setiap packet, sedangkan header tambahan hanya jika
diperlukan diselipkan antara header dasar dengan data. Header tambahan, saat ini didefinisikan
selain bagi penggunaan ketika packet dipecah, juga didefinisikan bagi fungsi sekuriti dan lain-lain.
Header tambahan ini, diletakkan setelah header dasar, jika dibutuhkan beberapa header maka
header ini akan disambungkan berantai dimulai dari header dasar dan berakhir pada data. Router
hanya perlu memproses header yang terkecil yang diperlukan saja, sehingga waktu pemrosesan
menjadi lebih cepat. Hasil dari perbaikan ini, meskipun ukuran header dasar membesar dari 20
bytes menjadi 40 bytes namun jumlah field berkurang dari 12 menjadi 8 buah saja. 


Label Alir dan Real Time Process
Header dari packet pada IPv6 memiliki field label alir (flow-label) yang digunakan untuk meminta
agar packet tersebut diberi perlakuan tertentu oleh router saat dalam pengiriman (pemberian
‘flag’). Misalnya pada aplikasi multimedia sedapat mungkin ditransfer secepatnya walaupun
kualitasnya sedikit berkurang, sedangkan e-mail ataupun WWW lebih memerlukan sampai dengan
akurat dari pada sifat real time.



 Router mengelola skala prioritas maupun resource seperti kapasitas komunikasi atau kemampuan
memproses, dengan berdasar pada label alir ini. Jika pada IPv4 seluruh packet diperlakukan sama,
maka p ada IPv6 ini dengan perlakuan yang berbeda terhadap tiap packet, tergantung dari isi
packet tersebut, dapat diwujudkan komunikasi yang aplikatif.
IPv6 Transition (IPv4 – IPv6)
Untuk mengatasi kendala perbedaan antara IPv4 dan IPv6 serta menjamin terselenggaranya
komunikasi antara pengguna IPv4 dan pengguna IPv6, maka dibuat suatu metode Hosts – dual
stack serta Networks – Tunneling pada hardware jaringan, misalnya router dan server.
Gambar Hosts – dual stack (IPv6 Transition)
Gambar Networks

 Jadi setiap router menerima suatu packet, maka router akan memilah packet tersebut untuk
menentukan protokol yang digunakan, kemudian router tersebut akan meneruskan ke layer
diatasnya.
Allokasi IPv6
Kebijakan allokasi IPv6:
􀂉 Regular allocations
♦ Peering dengan ≥ 3 subTLA (Top Level Aggregator) dan
♦ Merencanakan untuk menyediakan pelayanan IPv6 tidak lebih dari 12 bulan, atau
♦ Mempunyai ≥ 40 SLA (Site Level Aggregator) customer.
􀂉 Bootstrap
♦ Peering dengan ≥ 3 AS (Autonomous System Number) dan
♦ Merencanakan untuk menyediakan pelayanan IPv6 tidak lebih dari 12 bulan, atau
♦ Mempunyai ≥ 40 IPv4 customer, atau
♦ Mempunyai kemampuan 6bone experience.
Untuk mendapatkan allokasi IPv6 dari Asia Pacific Network Information Center (APNIC), anda
harus mengirimkan permohonan IPv6 menggunakan form http://www.apnic.net/apnic-bin/ipv6-
subtla-request.pl, untuk wilayah Indonesia anda bisa mengirimkan form permohonan IPv6 yang
juga bisa diambil dari homepage APNIC: http://www.apnic.net/apnic-bin/ipv6-subtla-request.pl,
kemudian mengirimkan form tersebut ke ip-request@apjii.or.id, tapi sebelumnya anda
mendaftarkan sebagai anggota APJII untuk mendapatkan pelayanan ini.
Saat ini telah terdapat beberapa vendor yang telah mendukung IPv6, diantaranya:
􀂙 IPv6 Ready: 3Com, Epilogue, Ericsson/Telebit, IBM, Hitachi, KAME, Nortel, Trumpet
􀂙 Beta Testing: Apple, Cisco, Compaq, HP, Linux community, Sun, Microsoft.
􀂙 Implementing: Bull, BSDI, FreeBSD, Mentat, NovelL,SGI, dan lain sebagainya.
Berdasarkan data dari 6BONE (http://www.6bone.net) saat ini telah terdapat 200 situs yang
terdapat di 39 negara yang telah bertarsipasi dalam pengembangan tentang IPv6 ini, dan terdapat
berbagai lembaga yang turut berpartisipasi mengadakan riset mengenai IPv6 ini, diantaranya
adalah: CAIRN, Canarie, CERNET, Chunghawa Telecom, DANTE, Esnet, Internet2, IPFNET,
NTT, Renater, Singren, Sprint, SURFnet, vBNS, WIDE.
IANA sebagai lembaga tertinggi untuk pembagian Internet Resource telah mengalokasikan IPv6
resource ke 3 Regional Internet Registries (RIR), dengan perincian sebagai berikut:
􀂃 APNIC : 2001:0200::/23
􀂃 ARIN : 2001:0400::/23
􀂃 RIPE NCC : 2001:0600::/23
Pada saat ini terdapat 3 Regional Internet Registries (RIR) yang telah mengalokasikan 49 allocate
IPv6 dengan perincian sebagai berikut :
􀂃 APNIC telah mengalokasikan 19 allokasi IPv6.
􀂃 RIPE NCC telah mengalokasi 21 allokasi IPv6.
􀂃 ARIN telah mengalokasikan 9 allokasi IPv6.
Untuk mendapatkan status daftar dari allokasi IPv6 oleh Regional Internet Registries anda bisa
mendapatkan informasi ini di situs 6Bone (http://www.6bone.net).

Kesimpulan & Saran
IPv4 yang merupakan pondasi dari Internet telah hampir mendekati batas akhir dari
kemampuannya, dan IPv6 yang merupakan protokol baru telah dirancang untuk dapat
menggantikan fungsi IPv4. Motivasi utama untuk mengganti IPv4 adalah karena keterbatasan dari
panjang addressnya yang hanya 32 bit saja serta tidak mampu mendukung kebutuhan akan
komunikasi yang aman, routing yang fleksibel maupun pengaturan lalu lintas data.
IPv6 yang memiliki kapasitas address raksasa (128 bit), mendukung penyusunan address secara
terstruktur, yang memungkinkan Internet terus berkembang dan menyediakan kemampuan routing
baru yang tidak terdapat pada IPv4. IPv6 memiliki tipe address anycast yang dapat digunakan
untuk pemilihan route secara efisien. Selain itu IPv6 juga dilengkapi oleh mekanisme penggunaan
address secara local yang memungkinkan terwujudnya instalasi secara Plug&Play, serta
menyediakan platform bagi cara baru pemakaian Internet, seperti dukungan terhadap aliran data
secara real-time, pemilihan provider, mobilitas host, end-to-end security, ataupun konfigurasi
otomatis.
Untuk informasi mengenai IPv6, kami sarankan anda untuk mengakses situs 6BONE
(http://www.6bone.net), pada situs ini anda bisa mendapatkan informasi mengenai status dan hasil
riset dari berbagai partisipan yang tergabung di 6BONE ini.
Selain itu anda bisa mendapatkan informasi mengenai IPv6 dengan mengunjungi situs berikut ini:
􀂾 http://www.6ren.net
􀂾 http://www.6tap.net
􀂾 http://www.ipv6.org
􀂾 http://www.ipv6forum.com
Selain itu, anda bisa mendapatkan informasi tentang IPv6 melalui RFC (Request for Comment),
sebagai berikut:
• RFC 2374, an IPv6 Aggregatable Global Unicast Address Format
• RFC 2373, IPv6 Addressing Architecture
• RFC 2460, IPv6 Specification
• RFC 2461, Neighbor Discovery for IPv6
• RFC 2462, IPv6 Stateless Address Autoconfiguration
• RFC 2463, Internet Control Message Protocol (ICMPv6) for the IPv6 Specification
• RFC 1886, DNS Extensions to support IPv6
• RFC 1887, An Architecture for IPv6 Unicast Address Allocation
• RFC 1981, Path MTU Discovery for IP version 6
• RFC 2023, IP version 6 over PPP
• RFC 2080, RIPng for IPv6
• RFC 2452, IP version 6 Management Information Base for the User Datagram Protocol
• RFC 2464, Transmission of IPv6 Packets over Ethernet Networks
• RFC 2465, Management Information Base for IP version 6: Textual Conventions and General
Group
• RFC 2466, Management Information Base for IP version 6: ICMPv6 Group
• RFC 2467, Transmission of IPv6 Packets over FDDI Networks
• RFC 2470, Transmission of IPv6 over Token Ring Networks
• RFC 2472, IP version 6 over PPP
• RFC 2473, Generic Packet Tunneling in IPv6 Specification
• RFC 2507, IP Header Compression
• RFC 2526, Reserved IPv6 Subnet Anycast Addresses
• RFC 2529, Transmission of IPv6 over IPv4 Domains without Explicit Tunnels
• RFC 2545, Use of BGP-4 Multiprotocol Extensions for IPv6 Inter-Domain Routing
• RFC 2590, Transmission of IPv6 Packets over Frame Relay
• RFC 2675, IPv6 Jumbograms
• RFC 2710, Multicast Listener Discovery (MLD) for IPv6
• RFC 2711, IPv6 Router Alert Option
• RFC 1888, OSI NSAPs and IPv6
• RFC 2292, Advanced Sockets API for IPv6
• RFC 2375, IPv6 Multicast Address Assignments
• RFC 2450, Proposed TLA and NLA Assignment Rules
• RFC 2471, IPv6 Testing Address Allocation
• RFC 2553, Basic Socket Interface Extensions for IPv6
Daftar Pustaka
􀂙 http://playground.sun.com/ipng
􀂙 http://www.6ren.net
􀂙 http://www.6tap.net
􀂙 http://www.ipv6.org
􀂙 http://www.ipv6forum.com
􀂙 http://www.apnic.net/policies.html
􀂙 http://www.apnic.net/drafts/ipv6/IPv6-FAQ.html
􀂙 http://www.apnic.net/drafts/ipv6/ipv6-policy-280599.html
􀂙 http://www.6bone.net/misc/case-for-ipv6.html
􀂙 Robert M. Hinden, IP Next Generation Overview,
http://playground.sun.com/pub/ipng/html/INET-Ipng-Paper.html

Merancang jaringan 5 Gedung

Materi perkuliahan kali ini adalah dengan mempresetasikan kerja kelompok. Adapun prinsip yang dapat dikembangkan yaitu:

Untuk perancangan antar gedung , digunakan prinsip routing, prinsip ini dapat menghubungkan segmen jaringan yang berbeda dengan menggunakan router.
Untuk perncangan jaringan internal atau dalam gedung dapat menggunakan teknik subnetting.
Topologi yang digunakan yaitu topoli mesh untuk antar gedung dan topologi star untunk internal dalam gedung
Untuk mencegah jaringan terputus dan memberikan alternatif makan diberikan pula dua buah koneksi internet.
Sebenarnya konsep ini masih memiliki kelemahan yakni boros kabel.

Hardware Yang di Butuhkan

Router
Swicth
PC komputer
Kabel jaringan
Wifi Hotspot terdapat pada gedung C

Konsep Perancangan

Perancangan jaringan ini menggunakan teknik bridge, dengan topologi mesh untuk di antar gedung, dan topologi star untuk dalam gedung.

Gedung A

Pada Gedung A ini ada 2 lantai, untuk tiap lantai memerlukan 2 buah switch yang mana setiap lantai memiliki jumlah host 10 buah. Pada gedung ini dibagi menjadi 2 segmen jaringan, dengan teknik subnetting Kemudian untuk konfigurasi IP kita menggunakan 192.168.101.0 /27

Kemudian IP 192.168.101.1 dipakai untuk gateway jaringan yang terpasang pada router.

Gedung B

Pada Gedung B ini ada 2 lantai, untuk tiap lantai memerlukan 2 buah switch yang mana setiap lantai memiliki jumlah host 10 buah. Pada gedung ini dibagi menjadi 2 segmen jaringan, dengan teknik subnetting Kemudian untuk konfigurasi IP kita menggunakan 192.168.102.0 /27

Kemudian IP 192.168.102.1 dipakai untuk gateway jaringan yang terpasang pada router.

Gedung C

Pada Gedung C ini ada 2 lantai, untuk tiap lantai memerlukan 2 buah switch yang mana setiap lantai memiliki jumlah host 10 buah. Pada gedung ini dibagi menjadi 2 segmen jaringan, dengan teknik subnetting Kemudian untuk konfigurasi IP kita menggunakan 192.168.103.0 /27. Khusus lantai 1 kita menggunakan layanan wireless dan konfigurasi IP client di atur oleh DHCP.

Kemudian IP 192.168.103.1 dipakai untuk gateway jaringan yang terpasang pada router.

Gedung D

Pada Gedung D ini ada 2 lantai, untuk tiap lantai memerlukan 2 buah switch yang mana setiap lantai memiliki jumlah host 10 buah. Pada gedung ini dibagi menjadi 2 segmen jaringan, dengan teknik subnetting Kemudian untuk konfigurasi IP kita menggunakan 192.168.104.0 /27

Kemudian IP 192.168.104.1 dipakai untuk gateway jaringan yang terpasang pada router.

Gedung E

Pada Gedung E ini ada 2 lantai, untuk tiap lantai memerlukan 2 buah switch yang mana setiap lantai memiliki jumlah host 10 buah. Pada gedung ini dibagi menjadi 2 segmen jaringan, dengan teknik subnetting Kemudian untuk konfigurasi IP kita menggunakan 192.168.105.0 /27

Kemudian IP 192.168.104.1 dipakai untuk gateway jaringan yang terpasang pada router.

Fitur-Fitur Dalam Perancangan Jaringan

1. Service

Ip Otomatis

DHCP (Dinamis Host Configuration Protocol). DHCP Relay yaitu service yang meneruskan IP secara otomatis. DHCP Authentifikasi berupa MAC ADdress.

Dynamic Host Configuration Protocol (DCHP) adalah protokol yang berbasis arsitektur client/server yang dipakai untuk memudahkan pengalokasian alamat IP dalam satu jaringan. Sebuah jaringan lokal yang tidak menggunakan DHCP harus memberikan alamat IP kepada semua komputer secara manual. Jika DHCP dipasang di jaringan lokal, maka semua komputer yang tersambung di jaringan akan mendapatkan alamat IP secara otomatis dari server DHCP. Selain alamat IP, banyak parameter jaringan yang dapat diberikan oleh DHCP, seperti default gateway dan DNS server.


RADIUS (Remote Access Dial In User Service). Digunakan untuk jarak jauh.


Remote Authentication Dial-In User Service (sering disingkat menjadi RADIUS) adalah sebuah protokol keamanan komputer yang digunakan untuk melakukan autentikasi, otorisasi, dan pendaftaran akun pengguna secara terpusat untuk mengakses jaringan. RADIUS didefinisikan di dalam RFC 2865 dan RFC 2866, yang pada awalnya digunakan untuk melakukan autentikasi terhadap akses jaringan secara jarak jauh dengan menggunakan koneksi dial-up. RADIUS, kini telah diimplementasikan untuk melakukan autentikasi terhadap akses jaringan secara jarak jauh dengan menggunakan koneksi selain dial-up, seperti halnya Virtual Private Networking (VPN), access point nirkabel, switch Ethernet, dan perangkat lainnya.


Radius banyak dipakai oleh Provider dan ISP internet untuk authentikasi dan billingnya. Radius juga bisa dipakai oleh jaringan RT/RW-Net untuk authentikasi para penggunanya dan untuk mengamankan jaringan RT/RW-Net yang ada. Di indonesia sudah ada service radius, namun berbayar seperti indohotspot.net . Ada juga service yang tidak berbayar, dan dikelola oleh luar negeri seperti chillidog.org Selain lebih menghemat budget, dan juga menghemat biaya maintenance, sistem Radius yang di host di internet merupakan salah satu solusi murah untuk para penggagas sistem HotSpot.


LDAP


LDAP (Lightweight Directory Access Protocol) adalah protokol perangkat lunak untuk memungkinkan semua orang mencari resource organisasi, perorangan dan lainnya, seperti file atau printer di dalam jaringan baik di internet atau intranet. Protokol LDAP membentuk sebuah direktori yang berisi hirarki pohon yang memiliki cabang, mulai dari negara (countries), organisasi, departemen sampai dengan perorangan. Dengan menggunakan LDAP, seseorang dapat mencari informasi mengenai orang lain tanpa mengetahui lokasi orang yang akan dicari itu.


2. Monitoring


SNMP(Simple Network Management Protocol).


Simple Network Management Protocol (SNMP) merupakan protokol standard industri yang digunakan untuk memonitor dan mengelola berbagai perangkat di jaringan Internet meliputi hub, router, switch, workstation dan sistem manajemen jaringan secara jarak jauh (remote). Baru-baru ini (pertengahan Februari 2002) Oulu University Secure Programming Group, sebuah group riset keamanan jaringan di Finlandia, telah menemukan adanya kelemahan pada SNMP v1.


Kelemahan tersebut memungkinkan seorang cracker memasang back door pada peralatan yang menggunakan SNMP v1 sehingga bisa menyusup ke jaringan dan melakukan apa saja terhadap jaringan. Kelemahan ditemukan pada SNMP trap and request facilities yang memungkinkan penyusup memperoleh akses ke dalam sistem yang menjalankan SNMP dan melakukan serangan Denial of Service (DoS) yang membuat sistem tidak berfungsi (down) atau tidak stabil.


MRTG


MRTG (the Multi Router Traffic Grapher) Adalah aplikasi yang digunakan untuk memantau beban trafik pada link jaringan. MRTG akan membuat halaman HTML yang berisi gambar GIF yang mengambarkan trafik melalui jaringan secara harian, mingguan, bulanan dan tahunan. MRTG dibuat oleh Tobias Oetiker menggunakan Perl dan C dan tersedia untuk sistim operasi UNIX dan Windows NT.


3. Routing Dinamis


OSPF


Open Shortest Path First (OSPF) adalah sebuah routing protokol standar terbuka yang telah di implementasikan oleh sejumlah besar vendor jaringan.


OSPF bekerja dengan sebuah algoritma yang disebut Dijkstra. Pertama, sebuah pohon jalur terpendek (shortest path tree) akan dibangun, dan kemudian routing table akan diisi dengan jalur terbaik yang dihasilkan dari pohon tersebut. OSPF melakukan converge dengan cepat, meskipun tidak secepat EIGRP, dan OSPF mendukung multiple route dengan biaya (cost) yang sama, ketujuan yang sama.


RIP


Routing Information Protocol (RIP) adalah sebuah protokol routing dinamis yang digunakan dalam jaringan LAN (Local Area Network) dan WAN (Wide Area Network). Karena itu protokol ini diklasifikasikan sebagai Interior Gateway Protocol (IGP). Protokol ini menggunakan algoritma Distance-Vector Routing. Pertama kali didefinisikan dalam RFC 1058 (1988). Protokol ini telah dikembangkan beberapa kali, sehingga terciptalah RIP Versi 2 (RFC 2453). Kedua versi ini masih digunakan sampai sekarang, meskipun begitu secara teknis mereka telah dianggap usang oleh teknik-teknik yang lebih maju, seperti Open Shortest Path First (OSPF) dan protokol OSI IS-IS. RIP juga telah diadaptasi untuk digunakan dalam jaringan IPv6, yang dikenal sebagai standar RIPng (RIP Next Generation / RIP generasi berikutnya), yang diterbitkan dalam RFC 2080 (1997).


BOP


TUGAS


Perancangan Jaringan komputer 2 Gedung


Perancangan ini dengan menggunakan sistem bridge

Ujian MID Semester TGL 13 mei 2011

Pertemuan digunakan untuk ujian mid semester

Syarat yng harus dipenuhi agar suatu komputer dengan komputer dapat saling terhubung adalah sebagai berikut, komputer tersebut harus berada pada:
1. Net id yang sama
2. host id tidak boleh sama
3. network yang sama
4. IP broadcast-nya sama

Tugas

Merakit jaringan komputer 6 lantai dengan masing-masing 30 PC perlantai.

STRUKTUR KABEL

Specifies:

* Cabling requirements

* Cabling distances
* Outlet / connector configurations
* Recommended topology
* Covers wide range of building sites and

applications


* Voice, data, text, video, image, etc.

* Up to 1,000,000 m2 office space
* Up to 50,000 users

Sttrructturred Cablliing:: Why?


* Provides flexibility

* Supports diverse environments
* Ensures reliable, high performance
* Allows for quick moves, adds, changes



Pengertian Struktur Kabel


• Adalah sebuah sistem struktur yang bekerja berdasarkan prinsip gaya tarik, terdiri atas kabel baja, sendi, batang, dsb yang menyanggah sebuah penutup yang menjamin tertutupnya sebuah bangunan. (Makowski, 1988)

• Struktur kabel dan jaringan dapat juga dinamakan struktur tarik dan tekan, karena pada kabel-kabel hanya dilimpahkan gaya-gaya tarik, sedangkan kepada tiang-tiang pendukungnya hanya dilimpahkan gaya tekan. (Sutrisno, 1983)

Sejarah Struktur Kabel

A. Sejarah Perkembangan Struktur Kabel
Asal mula struktur kabel
Struktur kabel merupakan salah satu struktur tradisional yang awalnya berupa jembatan dan tenda. Jembatan dengan sistem kabel tarik awalnya diterapkan pada daerah pegunungan seperti Himalaya atau di daerah hutan hujan seperti Peru. Kemudian berkembang hingga Eropa
yang diprakarsai oleh Faustus Verantinus pada tahun 1616 yang menggunakan rantai sebagai pengganti kabel yang dingkurkan pada menara. Pada saat itu hingga menjelang abad ke-20, kabel hanya menjadi sistem yang membantu perkuatan karena belum dapat mengatasi factor beban angin.
Bentuk tenda sering digunakan oleh suku nomaden di Eropa Utara, Asia dan Timur Tengah. Tenda-tenda tersebut dapat dikelompokkan atas tiga jenis, yaitu :
1. Bentuk kerucut dengan penutup dari kulit

Merupakan bentuk yang paling sederhana dengan satu atau lebih tiang utama di dalam dan beberapa tiang pembentuk yang menyatu di puncak tiang utama.


2. Bentuk silinder dengan atap perpaduan bentuk kubah dan kerucut


Dinding silinder dibentuk dengan batang-batang yang saling menyilang dengan batang pembentuk atap menyatu ditengah dan diperkuat dengan cincin


3. Bentuk black tent


Bentuk ini hanya menggunakan kabel tarik yang ditutupi terpal tanpa batang pengaku. Fungsi utamanya adalah sebagai perlindungan terhadap matahari dan temperature yang rendah pada malam hari.


C. Struktur kabel pada abad ke 19


Prinsip struktur kabel mengadaptasi bentuk tenda dan jembatan, hanya saja diterapkan pada bentang yang lebih luas. Dipicu oleh revolusi industri dimana terjadi pertambahan penduduk yang cepat dan pertumbuhan di bidang industri, mengakibatkan munculnya kebutuhan akan bangunan dengan bentang lebar untuk pabrik, stasiun kereta api dan fasilitas umum lainnya. Sistem struktur yang sering digunakan adalah struktur rangka sedangkan struktur kabel jarang digunakan. Namun terdapat beberapa contoh yang dapat diklasifikasikan menjadi :

• Perpaduan struktur kabel dengan elemen jembatan
Bangunan pertama adalah sebuah pabrik di pelabuhan Perancis yang dibangun tahun 1839. Terdiri atas dua gedung memanjang dengan ruang diantaranya sepanjang 40 m yang tertutup atap tanpa dinding. Atap didikat oleh sistem kabel catenary yang diangkurkan pada tower bangunan.
• Atap dengan rantai dan kabel tarik
Jaringan rantai besi atau kabel digunakan sebagai penutup atap, sebagai alternatif atap yang tahan api.
• Jaringan kabel dua arah pada lantai
Jaringan kabel dan batang besi digabung membentuk suatu plat lantai yang pre-tension
• Masted Structure
Diilhami oleh tuntutan bangunan berbentang lebar yang ringan, biaya rendah dan konstruksi yang tahan api, maka digunakan prinsip jembatan dengan mengikat rantai atau kabel (sebagai rangka atap) pada kolom yang diteruska ke atas

Dasar-Dasar Struktur Kabel

Daya Tarik yang tinggi dari baja dengan efisiensi tarik murni memungkinkan kabel baja sebagai elemen struktur yang dapat membentangi jarak besar. Kabel adalah fleksibel karena ukurannya dari sisi kecil dibandingkan dengan panjangnya. Fleksibel menunjukan daya lengkung yang terbatas.
Karena tegangan-tegangan lengkung tidak sama, dapat diatasi oleh fleksibelnya kabel. Beban-beban yang dipikul oleh batang-batang tarik terbagi di antara kabel-kabel. Masing-masing kabel memikul beban dengan tegangan yang sama dan di bawah tegangan yang diperkenankan.
Untuk mendapat gambaran mengenai mekanisme kabel yang memikul beban vertikal, dapat dilihat pada gambar dibawah ini, terlihat suatu kabel yang ujung-ujungnya dipegang kuat oleh angkur pada tembok dan dibebani beban P ditengahnya. Karena beban P, kedua bagian kabel tertarik dan membentuk segitiga, tiap bagian kabel memikul ½ p

Bentuk segitiga yang terbentuk oleh kabel memilki ciri khas lenturan,

yaitu jarak vertikal antara landasan gantung sampai dengan titik terendah pada kabel. Kabel tanpa lenturan tak dapat memikul beban karena gaya tarik yang terdapat dalam kabel yang mendatar tidak dapat mengadakan keseimbangan dengan gaya atau beban vertikal. Gaya tarik arah kedalam pada kedua landasan akibat melenturnya kabel dapat dibagi menjadi dua bagian yang sama karena pembebanan simetri. Bilamana landasan perletakan tidak cukup kuat, maka kedua bagian kabel akan berimpit menjadi satu. Untuk mengatasi hal tersebut, perlu dipasang batang penunjang mendatar antara kedua landasan. Mekanisme kabel

• Makin panjang kabel

- lenturan makin besar
- tetapi tegangan menjadi lebih rendah
- dapat dipakai kabel dengan potongan lintang yang kecil.
• Makin pendek kabel,
- lenturan pun makin kecil
- tegangan menjadi lebih tinggi
- diperlukan kabel dengan potongan lintang yang lebih besar.

2. Klasifikasi Struktur Kabel

Secara Garis Besar, Struktur kabel dapat dibedakan menjadi:
1. Struktur Kabel Tunggal Sistem Roda Sepeda ( Single Layer Sistem)

Pada sistem ini dipakai satu susunan kabel yang menghubungkan cincin dinding luar dari beton sebagai penahan tiang yang silindris ke cincin dalam di titik pusat lingkaran dari baja. Dinding tepi melingkar dibuat dari beton tulang yang tipis.

Penutup atap terdiri dari pelat beton prefabrikasi berbentuk baja yang didukung oleh kabel-kabel radial. Ujungnya ditekuk ke atas pada tulangan pelat. Agar stabil, pelat-pelat dibebani bata atau kantong-kantong berisi pasir sementara untuk memberi tarik tambahan pada kabel.
Lubang-lubang diantara dua pelat sebagai cetakan diisi adukan beron. Bilamana beton mongering, atap menjadi pelat yang monolit dan merupakan bundaran. Kabel akan memendek tetapi ditahan oleh beton tepi yang merupakan silinder yang telah membantu.
Jadi atap beton yang melengkung ke bawah itu mendapat prategang dari kabel-kabel, sehingga cukup kaku untuk menahan flutter effect (mengepak seperti sayap). Drainase air hujan dilakukan dengan memompa air yang ada di atas atap melalui pipa-pipa.

2. Struktur Kabel Ganda Sistem Roda Sepeda (Double Layer Sistem)

Sistem kabel ganda terdiri atas dua susunan kabel yang letaknya tidak sebidang, tidak berpotongan tetapi bersilang. Kedua susunan kabel ini merupakan struktur utama dari atap, susunan yang satu melengkung ke atas dan susunan yang lainnya melendut ke bawah. Kedua susunan kabel dijaga supaya tetap pada tempatnya oleh penunjang-penunjang tekan dengan berbagai panjang yang masing-masing dapat disetel.

Bahan atap terdiri dari pelat metal prefabrikasi. Atap bebas dari bahaya flutter effect karena gaya tarik dalam kabel yang cukup besar membuat susunan keseluruhan lebih kaku daripada kabel-kabel yang digantungkan.


2.3.5 Penerapan Struktur Kabel dalam Arsitektur

Struktur kabel merupakan suatu generalisasi terhadap beberapa struktur yang menggunakan elemen tarik berupa kabel sebagai ciri khasnya. Struktur ini bekerja terhadap gaya tarik sehingga lebih mudah berubah bentuk jika terjadi perubahan besar atau arah gaya. Struktur kabel merupakan struktur funicular dimana beban pada struktur diteruskan dalam bentuk gaya tarik searah dengan material konstruksinya, sehingga memungkinkan peniadaan momen.

A. Deformasi Struktur Kabel


Beban merata pada struktur kabel menyebabkan terbentuknya 2 macam kurva, yaitu :

• Kurva parabola, terjadi akibat beban horizontal yang merata
• Kurva katenari, terjadi akibat beban merata searah kabel

B. Sistem Stabilisasi

Beberapa sistem stabilisasi yang dapat digunakan untuk mengantisipasi deformasi pada struktur kabel antara lain :
1. Peningkatan beban mati
Stabilisasi ini dilakukan dengan penerapan material dengan berat yang memadai dan merupakan material yang homogen sehingga diperoleh beban yang terdistribusi merata.

2. Pengaku busur dengan arah berlawanan (inverted arch)

Stabilisasi dengan pengaku bususr atau kabel ini berusaha mencapai bentuk yang kaku dengan menambah jumlah kabel sehingga kemudian menghasilkan suatu jaring-jaring (cable net structure).

3. Penggunaan batang-batang pembentang (spreader)

Stabilisasi ini menggunakan batang-batang tekan sebagai pemisah antara dua kabel sehingga menambah tarikan internal didalam kabel.

4. Penambatan/pengangkuran ke pondasi (ground anchorage)

Sistem ini hanya berlaku bagi kabel karena adanya gaya-gaya taik yang dinetralisir oleh pondasi sehingga menghasilkan stabilisasi.Pada pondasi terjadi tumpuan tarik akibat perlawanan gaya tarik kabel.

5. Metoda prategang searah kabel (masted structure)

Ciri utamanya adalah tiang-tiang dan kabel yang secara keseluruhan membentuk suatu struktur kaku. Kabel ditempatkan pada keadaan tertegang dengan jalan memberikan beban yang dialirkan searah kabel.

2.3.6 Gaya-Gaya Pada Kabel

Untuk menghitung gaya-gaya kabel, dapat ditempuh dengan memanfaatkan keseimbangan titik-titik hubung struktur.
Kabel adalah struktur, dimana besar gaya-gaya pada kabel tersebut tidak konstan, ini berarti setiap segmen pada konstruksi kabel akan menerima gaya yang berbeda.
Tiupan angin diatas permukaan atap yang melendut menyebabkan terjadinya gaya isapan. Gaya isapan menyebabkan atap fleksibel mengarah cembung ke atas

Pada saat atap berubah bentuk sebagai akibat gaya isapan, pengaruh angin terhadap bentuk yang berubah tadi menyebabkan gaya tekan. Gaya tekan menyebabkan atap bergerak ke bawah


Pada saat bergerak ke bawah dan ke atas, efek angin secara bergantian tekan-isap yang mengakibatkan atap mengalami getar secara konstan


2.3.7 Keuntungan dan Kelemahan Struktur Kabel

• Keuntungan struktur kabel :
1. Elemen kabel merupakan elemen konstruksi paling ekonomis untuk menutup permukaan yang luas
2. Ringan, meminimalisasi beban sendiri sebuah konstruksi
3. Memiliki daya tahan yang besar terhadap gaya tarik, untuk bentangan ratusan meter mengungguli semua sistem lain
4. Memberikan efisiensi ruang lebih besar
5. Memiliki faktor keamanan terhadap api lebih baik dibandingkan struktur tradisonal yang sering runtuh oleh pembengkokan elemen tekan di bawah temperatur tinggi. Kabel baja lebih dapat menjaga konstruksi dari temperatur tinggi dalam jangka waktu lebih panjang, sehingga mengurangi resiko kehancuran
6. Dari segi teknik, pada saat terjadi penurunan penopang, kabel segera menyesuaikan diri pada kondisi keseimbangan yang baru, tanpa adanya perubahan yang berarti dari tegangan
7. Cocok untuk bangunan bersifat permanen.

• Kelemahan struktur kabel :

Pembebanan yang berbahaya untuk struktur kabel adalah getaran. Struktur ini dapat bertahan dengan sempuna terhadap gaya tarik dan tidak mempunyai kemantapan yang disebabkan oleh pembengkokan, tetapi struktur dapat bergetar. Dalam hal gejala resonansi yang umum dikenal dapat timbul dan mengakibatkan robohnya bangunan.

SISTEM OPERASI JARINGAN (NOS)

Sistem operasi jaringan merupakan sebuah jenis sistem operasi yang ditujukan untuk menangani jaringan yang didesain terutama untuk mendukung printer sharing, common file system dan database sharing, application sharing dan kemampuan untuk me-manage suatu network name directory, system keamanan, dan pengawasan segala aspek jaringan.
Sistem operasi jaringan atau sistem operasi komputer yang dipakai sebagai server dalam jaringan komputer hampir mirip dengan sistem operasi komputer stand alone, bedanya hanya pada sistem operasi jaringan, salah satu komputer harus bertindak sebagai server bagi komputer lainnya. Sistem operasi dalam jaringan disamping berfungsi untuk mengelola sumber daya dirinya sendiri juga untuk mengelola sumber daya komputer lain yang tergabung dalam jaringan.
Perangkat lunak dalam sebuah jaringan komputer terdiri dari dua perangkatutama, yaitu:
• Perangkat lunak sistem operasi jaringan.
• Sistem aplikasi yang digunakan untuk bekerja
Sistem operasi komputer telah mengalami perkembangan yang sangat pesat baik untuk keperluan stand alone maupun jaringan. Ada banyak sistem operasi komputer yang dapat digunakan dalam sebuah komputer baik stand alone maupun jaringan diantaranya adalah
  • Microsoft Windows Series (Win 3.1, Win 9x, Win ME, Win 2000, Win XP, Win NT, Win Vista)
  • Unix
  • San Solaris
  • Linux Series (Redhat, Debian, SUSE, Mandrake, Knoppix)
  • Mac, dan lain sebagainya.
Masing-masing sistem operasi memiliki kelebihan dan kekurangan sehingga diperlukan analisis dalam memilih sistem operasi mana yang sesuai dengan kebutuhan.
Beberapa kategori yang sebagai prasyarat untuk memilih Network Operating System (NOS) yang sesuai kebutuhan sebagai berikut :
a. Architecture
Perusahaan-perusahaan yang memiliki beban kerja yang dinamis perlu memperhatikan arsitektur NOS
b. Scalability
Beberapa hal pertimbangan pemilihan NOS untuk mendukung skala usaha yang menggunakan NOS
c. Availability dan Reliability
Memiliki fitur file locking, mendukung RAID (Redudant Arrays of Inexpensive Disk), berbagai tipe dari pengalihan kegagalan pada klien (client failover) ketika suatu server mengalami kegagalan dan mendukung konfigurasi fault-tolerant hardware. ini semua merupakan hal yang penting untuk perusahaan yang mengandalkan jaringan sebagai bagian kritis dari operasi bisnis harian mereka.
d. Clients supported
Kebanyakan perusahaan memiliki berbagai macam operating sistem di setiap dekstopnya diantaranya: DOS, DOS/Windows, Windows for Workgroup, Windows 95/98, Windows NT Workstation, Macintosh, OS/2 dan Unix serta peralatan-peralatan seperti terminal X-Windows, terminal character cell(teller terminal, point of sale devices dll). Suatu NOS harus dapat mendukung semua hal di atas.
e. Network Printing
Printing merupakan salah satu dari fungsi-fungsi utama dari NOS. Perusahaan harus dapat mengetahui jawaban dari beberapa hal berikut dalam memilih NOS :
Berapa jumlah printer yang mampu didukung setiap server
Printer banyak Dapat dikendalikan oleh satu antrian print
Dapatkah banyak antrian print mengendalikan satu printer
Dapatkah NOS membangkitkan sinyal alarm ke operator jika timbul masalah ketika mencetak
Dapatkah NOS memberitahu pemakai apabila tugas pencetakan telah selesai
Dapatkah fungsi pencetakan di-manage dari jauh
f. Network Media
Berbagai tipe media jaringan telah banyak digunakan dalam perusahaan seperti media Ethernet, Token Ring, asynchronous dan synchronous telephone lines, Packet Switched Data Networks(PSDN) seperti X.25, fiber optic dan Integrated Services Digital Network (ISDN). Tanpa kemampuan dukungan terhadap semua hal di atas maka sangat sukar bagi suatu perusahaan untuk membangun infrastuktur jaringan yang paling optimal untuk kebutuhan jaringannya.
g. Network Protocols
Pemilihan NOS harus mempertimbangkan kompatibilitas antara protocol jaringan yang digunakan dengan NOS yang meliputi 3270 dan asynchronous terminal emulation, AppleTalk filing protocol (AFP), TCP/IP, Telnet, Simple Mail Transfer Protocol (SMTP), Simple Network Management Protocol (SNMP), SNA, SNA LU6.2, SNA Advanced Program-to-Program Communication (APPC), File Transfer Protocol (FTP), Internetwork Packet Exchange/Sequenced Packet Exchange (IPX/SPX), NetWare file services, NetWare print services, NetBIOS, dan NetBEUI. Kategori ini juga mempertimbangkan apakah akses client ke server melalui suatu saluran asynchronous, PSDN, Internet atau ISDN.
h. Network Services
Kategori ini untuk mengevaluasi platform NOS untuk menentukan apakah NOS tersebut menyediakan fungsi-fungsi yang diperlukan untuk directory services yang mengijinkan user mengakses layanan jaringan tanpa perlu mengetahui alamat jaringan, layanan keamanan yang mengontrol akses ke fungsi-fungsi directory management dan menentukan apakah NOS mendukung tool-tool dan layanan-layanan yang sudah dispesifikasikan oleh Dekstop Management Task Force (DMTF).
i. Server Management
Memastikan ketersediaan tool untuk me-manage platform NOS, termasuk audit trail functions, file management, user account management, error reporting, dan server performance reporting. Perusahaan memerlukan informasi ini untuk peng-administrasian NOS platform.
j. Security
Mengevaluasi kesesuaian standar platform NOS, dukungan terhadap access control list, disk quotas, automatic discovery dan management dari penyusup, dukungan terhadap callback modem, dukungan terhadap security management system seperti Kerberos, dan apakah encryption services tersedia.
k. Functionality/Utility
Proses konsolidasi server-server fungsi tunggal ke dalam server-server multi fungsi harus mengevaluasi insfrastruktur platform NOS. Suatu operating system fungsi tunggal dapat menyediakan kinerja yang lebih tinggi untuk layanan file dan print namun memerlukan dukungan operating system lain untuk sebagai platform layanan aplikasi. Suatu general purpose operating system dapat mendukung mutlifunctions server sehingga dapat mengurangi management dan biaya sistem.
l. Application development tools
NOS platform harus dapat mendukung layanan aplikasi sebaik dukungan terhadap layanan file dan print. Kategori ini meninjau ketersediaan dari third generation language (3GLs), fourth generation language (4GLs), object oriented development tools dan tool untuk team programming di setiap NOS paltform.
m. Data access
NOS platform harus dapat mendukung aplikasi-aplikasi yang lebih kompleks sehingga harus juga mendukung file access methode dan indexed file access method. Kategori ini mengevaluasi dukungan NOS platform untuk file services.
n. Database support
Software database biasanya merupakan bagian dari infrastuktur distributed applications. Kategori ini mengevaluasi software database yang tersedia pada setiap NOS platform.
o. Applications
Kategori ini untuk mengevaluasi layanan aplikasi apa saja yang tersedia pada setiap NOS platform seperti mail client, mail server, word proccessing client, spreadsheet

Pacth Panel

Patch cable adalah segmen kabel UTP yang dipakai untuk menghubungkan kartu interface jaringan ke wall jack atau untuk menghubungkan bagian-2 lain dari instalasi kabel jaringan ini.
Patch panel merupakan panel penghubung yang menyediakan multi port yang menyalurkan kabel-2 ke piranti-2 atau hardware penghubung lainnya seperti switch.

Kegunaan Patch Panel

Sebuah patch panel memisahkan peralatan  jaringan kabel (switch, router) dari perangkat jaringan (komputer, printer, scanner) . Setiap kabel yang berasal dari peralatan jaringan akan tersambung ke belakang patch panel. Setelah itu patch panel akan terhubung dengan switch unmanaged/managed melalui kabel utp penghubung (disebut: patch cable/patch cord). Berikut adalah apa pukulan ke daerah di belakang panel patch terlihat seperti:



Pada port RJ45, sisi ini dilengkapi dengan slot punch down dan diberi warna T568A dan T568B . Ada juga pengujian simbol verifikasi independen untuk UL dan 3P.
Setiap slot punch down disambung sesuai ke port di bagian depan panel. Patch Kabel menghubungkan port di bagian depan panel patch (atau panel) untuk peralatan jaringan Anda (seperti switch, hub, dan router).
Beberapa orang lebih terbiasa menyambungkan perangkat jaringan (komputer, scanner, printter) langsung menuju port switch atau hub tanpa melalui patch panel. Ini dapat dilakukan bila anggaran installasi jaringan minim, tetapi hal tersebut dapat membingungkan dan menyulitkan proses perubahan di masa mendatang. Karena susunan kabel tidak lebih teratur dari susunan kabel yang menggunakan patch panel.

KomPoneN Main Board

Mainboard adalah papan sirkuit yang digunakan untuk meletakan komponen-komponen CPU untuk pemasangan hardware. Seperti yang dipaparkan fungsi Mainboard adalah sebagai media tempat untuk menghubungkan komponen-komponen hardware agar komputer dapat bekerja, juga merupakan media terbesar yang ada dalam CPU. Pada Mainboard terpasang pula kabel penghubung dari Power Supply, kabel tersebut yang memberikan sumber arus listrik agar Mainboard dapat bekerja.


Komponen pada mainboard


# Chipset adalah tulang belakang dan saraf pusat otak. Karena chipset ini mengatur hubungan antara processor dengan piranti lainnya, maka chipset akan menetapkan kecepatan processor yang digunakan sekaligus jenisnya, kecepatan bus, jenis memory, jumlah memory dan kecepatannya. Dapat dikatakan bahwa chipset ini lebih penting dibanding processor.


* North Bridge, chip ini merupakan penghubung antara bus dan processor.


*South Bridge, yang menjembatani bus PCI dan bus ISA yang lambat.


#System bus atau bus sistem, dalam arsitektur komputer merujuk pada bus yang digunakan oleh sistem komputer untuk menghubungkan semua komponennya dalam menjalankan tugasnya. Sebuah bus adalah sebutan untuk jalur di mana data dapat mengalir dalam komputer. Jalur-jalur ini digunakan untuk komunikasi dan dapat dibuat antara dua elemen atau lebih. Data atau program yang tersimpan dalam memori dapat diakses dan dieksekusi oleh CPU melalui perantara sistem bus.


Sebuah komputer memiliki beberapa bus, agar dapat berjalan. Banyaknya bus yang terdapat dalam sistem, tergantung dari arsitektur sistem komputer yang digunakan. Sebagai contoh, sebuah komputer PC dengan prosesor umumnya Intel Pentium 4 memiliki bus prosesor (Front-Side Bus), bus AGP, bus PCI, bus USB, bus ISA (yang digunakan oleh keyboard dan mouse), dan bus-bus lainnya.


· Bus AGP (Accelerated Graphic Port). Bus ini merupakan bus yang didesain secara spesifik untuk kartu grafis. Bus ini berjalan pada kecepatan 66 MHz (mode AGP 1x), 133 MHz (mode AGP 2x), atau 533 MHz (mode AGP 8x) pada lebar jalur 32-bit, sehingga bandwidth maksimum yang dapat diraih adalah 2133 MByte/s. Umumnya, bus ini terkoneksi ke chipset pengatur memori (Northbridge, Intel Memory Controller Hub, atau NVIDIA nForce SPP). Sebuah sistem hanya dapat menampung satu buah bus AGP. Mulai tahun 2005, saat PCI Express mulai marak digunakan, bus AGP ditinggalkan.


· Bus PCI (Peripherals Component Interconnect). Bus PCI tidak tergantung prosesor dan berfungsi sebagai bus peripheral. Bus ini memiliki kinerja tinggi untuk sistem I/O berkecepatan tinggi. Bus ini berjalan pada kecepatan 33 MHz dengan lebar lajur 32-bit. Bus ini ditemukan pada hampir semua komputer PC yang beredar, dari mulai prosesor Intel 486 karena memang banyak kartu yang menggunakan bus ini, bahkan hingga saat ini. Bus ini dikontrol oleh chipset pengatur memori (northbridge, Intel MCH) atau Southbridge (Intel ICH, atau NVIDIA nForce MCP).


· Bus PCI Express (Peripherals Component Interconnect Express)


· Bus PCI-X (Peripherals Component Interconnect Express)


· Bus ISA (Industry Standard Architecture)


· Bus EISA (Extended Industry Standard Architecute)


· Bus MCA (Micro Channel Architecture)


· Bus SCSI (Small Computer System Interface]]. Bus ini diperkenalkan oleh Macintosh pada tahun 1984. SCSI merupakan antarmuka standar untuk drive CD-ROM, peralatan audio, harddisk, dan perang· AGP BUS : Bus cepat 32 bit yang khusus untuk kartu Grafis/ Video. Berjalan pada kecepatan 66Mhz (AGP 1X), 133Mhz (AGP 2X), 266Mhz (AGP 4X) atau 533Mhz (AGP 8 X), yang akan menghasilkan bandwith hingga sebesar 2.133mb/det. AGP dihubungkan pada north-bridge atau Memory Controller Hub pada chipset dan konektornya pada motherboard diwujukan dalam bentuk slot AGP.


· PCI BUS : Bus 32 bit yang normalnya berjalan pada 33Mhz. Komputer yang modern mendukung PCI 64 bit 66 Mhz. Bus ini terdapat baik pada chipset north-bridge atau pada I/O Controller HUB.


· ISA BUS : Bus 16 Bit 8 Mhz. Kecepatan ini sangat rendah namun ideal untuk peripheral yang memang berkecepatan rendah, termasuk piranti lama. Untuk keperluan modem, sound card dan piranti kecepatan rendah lain, bus ini masih mencukupi. Komputer generasi terakhir relatif tidak menyertakan bus/ slot ini didalamnya. Pada chipset south-bridge terdapat controller yang bekerja sebagai bus ISA sekaligus interface dengan bus PCI diatasnya. Chip Super I/O biasanya terhubung kepadanya, terutama Chip Super I/O biasanya terhubung kepadanya, terutama pada sistem lama yang masih memiliki slot ISA.kat penyimpanan eksternal berukuran besar.


#BIOS (Basic Input/Output System) secara sederhana merupakan sebuah system di dalam Chip Motherboard yang bertugas mengenali dan menyiapkan perangkat keras/hardware komputer saat PC dinyalakan, seperti Hardisk, Processor, Floppy Disk, Memory, DVD Rom dan lainnya. Jika semua beres maka Sistem Operasi (seperti windows,Linux) baru mulai dijalankan.Fungsi primer dari BIOS adalah untuk mengidentifikasi dan menginisialisasi komponen hardware sistem computer, seperti kartu grafis, harddisk, dan floppy disk, juga beberapa hardware lainnya.
BIOS berguna untuk menyiapkan mesin computer ke dalam status kapabilitas computer yang normal, sehingga software lain yang disimpan di berbagai media, dapat ditampilkan, dijalankan dan dapat dikontrol oleh PC. Proses ini dinamakan booting atau booting up, atau yang sering dikenal dengan nama bootstrapping.


#Baterai C-MOS berfungsi untuk memberi tenaga pada motherboard dalam mengenali konfigurasi yang terpasang, ketika ia tidak atau belum mendapatkan daya dari power supply. Fungsi utama baterai CMOS adalah untuk mensuplai tenaga bagi BIOS untuk melakukan settingan terhadap sebuah mainboard. Perlu Anda ketahui, BIOS merupakan sebuah aplikasi bawaan dari mainboard untuk dapat melakukan pengontrolan dan pendeteksian terhadap komponen-komponen lain yg terhubung ke mainboard (hardware lain). Melalui BIOS, Anda dapat melakukan pengaturan terhadap kinerja serta fungsi-fungsi sebuah mainboard. BIOS memiliki chipset tersendiri dalam sebuah mainbord, dgn ukuran yg cukup kecil (sekitar 1cm). Didekat chipset BIOS itulah terletak baterai CMOS. Selain fungsi utama tersebut, BIOS memiliki fungsi untuk pengaturan waktu (jam dan tanggal) dikomputer Anda. Pada BIOS Anda dapat melakukan pengaturan seperti konfigurasi BOOT Device, Video Share, CPU Speed, dan lainnya.


#Read-only Memory (ROM) adalah istilah bahasa Inggris untuk medium penyimpanan data pada komputer. ROM adalah singkatan dari Read-Only Memory, ROM ini adalah salah satu memori yang ada dalam computer. ROM ini sifatnya permanen, artinya program / data yang disimpan didalam ROM ini tidak mudah hilang atau berubah walau aliran listrik di matikan.

CISC vs RISC

Sudah sering kita mendengar debat yang cukup menarik antara komputer personal IBM dan kompatibelnya yang berlabel Intel Inside dengan komputer Apple yang berlabel PowerPC.  Perbedaan utama antara kedua komputer itu ada pada tipe prosesor yang digunakannya. Prosesor PowerPC dari Motorola yang menjadi otak utama komputer Apple Macintosh dipercaya sebagai prosesor RISC, sedangkan Pentium buatan Intel diyakini sebagai prosesor CISC. Kenyataannya komputer personal yang berbasis Intel Pentium saat ini adalah komputer personal yang paling banyak populasinya. Tetapi tidak bisa pungkiri juga bahwa komputer yang berbasis RISC seperti Macintosh, SUN adalah komputer yang handal dengan sistem pipelining, superscalar, operasi floating point dan sebagainya.
Apakah memang RISC lebih lebih baik dari CISC atau sebaliknya. Tetapi tahukah kita dimana sebenarnya letak perbedaan itu. Apakah prosesor dengan instruksi yang lebih sedikit akan lebih baik dari prosesor yang instruksinya kompleks dan lengkap. Apakah memang perbedaan prosesor itu hanya dari banyak atau tidaknya instruksi saja. Bukankah jumlah instruksi tidak berhubungan dengan ke-handal-an suatu prosesor. Pertanyaan-pertanyaan ini yang hendak dijawab melalui tulisan berikut. Namun supaya lebih dekat dengan elektronika praktis,  ElectronicLab akan lebih fokus pada mikrokontroler low-cost yang berbasis RISC dan CISC. Sebagai contoh dari mikrokontroler CISC adalah 68HC11 buatan Motorola dan  80C51 dari Intel. Kita juga mengenal keluarga PIC12/16CXX dari Microchip dan COP8 buatan National Semiconductor sebagai mikrokontroler yang berbasis RISC.   
CISC adalah singkatan dari Complex Intruction Set Computer dimana prosesor tersebut memiliki set instruksi yang kompleks dan lengkap. Sedangkan RISC adalah singkatan dari Reduced Instruction Set Computer yang artinya prosesor tersebut memiliki set instruksi program yang lebih sedikit. Karena perbedaan keduanya ada pada kata set instruksi yang kompleks atau sederhana (reduced), maka mari kita bahas sedikit tentang intruksi itu sendiri.
Sistem mikrokontroler selalu terdiri dari perangkat keras (hardware) dan perangkat lunak (software). Perangkat lunak ini merupakan deretan perintah atau instruksi yang dijalankan oleh prosesor secara sekuensial. Instruksi itu sendiri sebenarnya adalah bit-bit logik 1 atau 0 (biner) yang ada di memori program. Angka-angka biner ini jika lebarnya 8 bit disebut byte dan jika 16 bit disebut word. Deretan logik biner inilah yang dibaca oleh prosesor sebagai perintah atau instruksi. Supaya lebih singkat, angka biner itu biasanya direpresentasikan dengan bilangan hexa (HEX). Tetapi bagi manusia, menulis program dengan angka biner atau hexa sungguh merepotkan. Sehingga dibuatlah bahasa assembler yang direpresentasikan dengan penyingkatan kata-kata yang cukup dimengerti oleh manusia. 
Bahasa assembler ini biasanya diambil dari bahasa Inggris dan presentasinya itu disebut dengan Mnemonic. Masing-masing pabrik  mikroprosesor melengkapi chip buatannya dengan set instruksi yang akan dipakai untuk membuat program.
Biner          Hexa   Mnemonic   
10110110   B6      LDAA ...
10010111   97      STAA ...
01001010   4A      DECA ...
10001010   8A     ORAA ...
00100110   26      BNE ...
00000001   01      NOP...
01111110   7E      JMP ...

Sebagian set instruksi 68HC11 
Pada awalnya, instruksi yang tersedia amat sederhana dan sedikit. Kemudian desainer mikroprosesor berlomba-lomba untuk melengkapi set instruksi itu selengkap-lengkapnya. Jumlah instruksi itu berkembang seiring dengan perkembangan desain mikroprosesor yang semakin lengkap dengan mode pengalamatan yang bermacam-macam. Mikroprosesor lalu memiliki banyak instruksi manipulasi bit dan seterusnya dilengkapi dengan instruksi-instruksi aritmatik seperti  penjumlahan, pengurangan, perkalian dan pembagian. Seperti contohnya 68HC11 banyak sekali memiliki set instruksi untuk percabangan seperti BNE, BLO, BLS, BMI, BRCLR, BRSET dan sebagainya. 
Perancang mikroprosesor juga memperkaya  ragam instruksi tersebut dengan membuat satu instruksi tunggal untuk program yang biasanya dijalankan dengan beberapa intruksi. Misalnya pada 80C51 untuk contoh program berikut ini.
LABEL    ...
                ...
                DEC    R0
                MOV  A,R0
                JNZ     LABEL

Program 'decrement' 80C51
Program ini adalah program pengulangan yang mengurangi isi register R0 sampai register R0 menjadi kosong (nol). Intel menambah set instruksinya dengan membuat satu instruksi khusus untuk keperluan seperti ini :
LABEL    ....  
                DJNZ   R0,LABEL  
Instruksi 'decrement jump not zero'  80C51 
Kedua contoh program ini hasilnya tidak berbeda. Namun demikian, instruksi kompleks seperti DJNZ mempermudah pembuat program. Set instruksi yang lengkap diharapkan akan semakin membuat pengguna mikroprosesor leluasa menulis  program dalam bahasa assembler yang mendekati bahasa pemrograman level tinggi. Intel 80C51 yang  dikembangkan dari basis prosesor 8048 dirilis pada tahun 1976 memiliki  tidak kurang dari 111 instruksi. Tidak ketinggalan, 68HC11 dari Motorola yang populer di tahun 1984 dilengkapi dengan 145 instruksi. Karena banyak dan kompleksnya instruksi yang dimiliki 68HC11 dan 80C51, kedua contoh mikrokontroler ini disebut sebagai prosesor CISC. 
Debat CISC versus RISC dimulai ketika pada tahun 1974 IBM mengembangkan prosesor 801 RISC. Argumen yang dipakai waktu itu adalah mengapa diperlukan instruksi yang kompleks. Sebab pada prinsipnya, instruksi yang kompleks bisa dikerjakan oleh instruksi-instruksi yang lebih sederhana dan kecil. Ketika itu penggunaan bahasa tingkat tinggi seperti Fortran dan kompiler lain (compiler/interpreter) mulai berkembang. Apalagi saat ini compiler seperti C/C++ sudah lazim digunakan. Sehingga sebenarnya tidaklah diperlukan instruksi yang kompleks di tingkat prosesor. Kompiler yang akan bekerja men-terjemahkan program  dari bahasa tingkat tinggi menjadi bahasa mesin. 
Untuk melihat bagaimana perbedaan instruksi RISC dan CISC, mari kita lihat bagaimana keduanya melakukan perkalian misalnya c = a x b.  Mikrokontroler 68HC11 melakukannya dengan program sebagai berikut :
LDAA #$5
LDAB #$10
MUL

Program 5x10 dengan 68HC11
Cukup tiga baris saja dan setelah ini accumulator D pada 68HC11 akan berisi hasil perkalian dari accumulator A dan B, yakni 5 x 10 = 50. Program yang sama dengan PIC16CXX, adalah seperti berikut ini. 
             MOVLW 0x10
             MOVWF Reg1
             MOVLW 0x05
             MOVWF Reg2
             CLRW
LOOP  ADDWF  Reg1,0
             CFSZ      Reg2,1
             GOTO     LOOP
             …
             …
Program 5x10 dengan PIC16CXX

Prosesor PIC16CXX yang RISC ini, tidak memiliki instruksi perkalian yang khusus. Tetapi perkalian 5x10 itu sama saja dengan penjumlahan nilai 10 sebanyak 5 kali. Kelihatannya membuat program assembly dengan prosesor RISC menjadi lebih kompleks dibandingkan dengan prosesor CISC. Tetapi perlu diingat, untuk membuat instruksi yang kompleks seperti instruksi MUL dan instruksi lain yang rumit pada prosesor CISC, diperlukan hardware yang kompleks juga. Dibutuhkan ribuan gerbang logik (logic gates) transistor untuk membuat prosesor yang demikian. Instruksi yang kompleks juga membutuhkan jumlah siklus mesin (machine cycle) yang lebih panjang untuk dapat menyelesaikan eksekusinya. Instruksi perkalian MUL pada 68HC11 memerlukan 10 siklus mesin dan instruksi pembagiannya memerlukan 41 siklus mesin.
Pendukung RISC berkesimpulan, bahwa prosesor yang tidak rumit akan semakin cepat dan handal. Hampir semua instruksi prosesor RISC adalah instruksi dasar (belum tentu sederhana),  sehingga instruksi-instruksi ini umumnya hanya memerlukan 1 siklus mesin untuk menjalankannya. Kecuali instruksi percabangan yang membutuhkan 2 siklus mesin. RISC biasanya dibuat dengan arsitektur Harvard, karena arsitektur ini yang memungkinkan untuk membuat eksekusi instruksi selesai dikerjakan dalam  satu atau dua siklus mesin.
Sebagai perbandingan jumlah instruksi pada prosesor RISC,  COP8 hanya dilengkapi dengan 58 instruksi dan PIC12/16CXX hanya memiliki 33 instruksi saja. Untuk merealisasikan instruksi dasar yang jumlah tidak banyak ini, mikroprosesor RISC tidak memerlukan gerbang logik yang banyak. Karena itu dimensi dice IC dan konsumsi daya prosesor RISC umumnya lebih kecil dibanding prosesor CISC. Bukan karena kebetulan, keluarga mikrokontroler PICXX banyak yang dirilis ke pasar dengan ukuran mini. Misalnya PIC12C508 adalah mikrokontroler DIP 8 pin. 
CISC dan RISC perbedaannya tidak signifikan jika hanya dilihat dari terminologi set instruksinya yang kompleks atau tidak (reduced). Lebih dari itu, RISC dan CISC berbeda dalam filosofi arsitekturnya. Filosofi arsitektur CISC adalah memindahkan kerumitan software ke dalam hardware. Teknologi pembuatan IC saat ini memungkinkan untuk menamam ribuan bahkan jutaan transistor di dalam satu dice. Bermacam-macam instruksi yang mendekati bahasa pemrogram tingkat tinggi dapat dibuat dengan tujuan untuk memudahkan programmer membuat programnya. Beberapa prosesor CISC umumnya memiliki microcode berupa firmware internal di dalam chip-nya yang berguna untuk menterjemahkan instruksi makro. Mekanisme ini bisa memperlambat eksekusi instruksi, namun efektif untuk membuat instruksi-instruksi yang kompleks. Untuk aplikasi-aplikasi tertentu yang membutuhkan singlechip komputer, prosesor CISC bisa menjadi pilihan.
Sebaliknya, filosofi arsitektur RISC adalah arsitektur prosesor yang tidak rumit dengan membatasi jumlah instruksi hanya pada instruksi dasar yang diperlukan saja. Kerumitan membuat program dalam bahasa mesin diatasi dengan membuat bahasa program tingkat tinggi dan compiler yang sesuai. Karena tidak rumit, teorinya mikroprosesor RISC adalah mikroprosesor yang low-cost dalam arti yang sebenarnya. Namun demikian, kelebihan ruang pada prosesor RISC dimanfaatkan untuk membuat sistem-sistem tambahan yang ada pada prosesor modern saat ini. Banyak prosesor RISC yang di dalam chip-nya dilengkapi dengan sistem superscalar, pipelining, caches memory, register-register dan sebagainya, yang tujuannya untuk membuat prosesor itu menjadi semakin cepat. 
Jadi mana yang lebih baik apakah RISC atau CISC, anda tentu punya pendapat sendiri.
--end--